Etrieve Degraded Performance
Incident Report for SBCC IT
Resolved
This issue has been resolved.
Posted Apr 05, 2024 - 13:18 PDT
Monitoring
We have received reports that Etrieve is running slow for some users. We are waiting for the vendor to fix the issue on their end. Another update will be posted when the issue has been resolved.
Posted Apr 04, 2024 - 12:37 PDT
This incident affected: Softdocs Etrieve.