Single Sign On

Incident Report for SBCC IT

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 07:58 PDT

Investigating

We have identified an issue with SSO, not all users will be affected. We are working to resolve the issue.
Posted Jun 01, 2026 - 15:09 PDT
This incident affected: Single Sign On Login and Softdocs Etrieve.