Power is back up at Schott campus. We are continuing to monitor the situation and will provide an update as more information becomes available.
Posted Oct 29, 2025 - 12:42 PDT
Investigating
Power has once again gone down at Schott campus. SCE is still investigating the problem and we are continuing to monitor the situation. This incident status will be updated as more information becomes available.
Posted Oct 29, 2025 - 11:54 PDT
Monitoring
Power has been restored to the Schott campus. We are continuing to monitor until 1:30pm.
Posted Oct 29, 2025 - 11:48 PDT
Update
SCE has provided an estimated time of 1:30pm today for service restoration. This incident status will be updated as more information becomes available.
Posted Oct 29, 2025 - 11:27 PDT
Investigating
An unplanned power outage has occurred at the Schott campus. We do not yet have an estimate from SCE as to when services will be restored. This incident status will be updated as more information becomes available.
Posted Oct 29, 2025 - 10:50 PDT
This incident affected: Campus Network Connectivity (Schott Campus) and Campus Telephony (Schott Campus telephones).