Softdocs (Etrieve) Issues

Incident Report for SBCC IT

Resolved

From Softdocs:

"Cloudflare Global Network experiencing issues

All sites are online and we have verified that all centralized services are running as expected. Please reach out to our support team if you are experiencing issues."
Posted Nov 18, 2025 - 11:52 PST

Monitoring

Cloudflare Global Network experiencing issues. This could be affecting many systems in the world, but specifically this is causing issue with Softdocs products. https://status.softdocs.com/
Posted Nov 18, 2025 - 07:35 PST
This incident affected: Softdocs Etrieve.