Etrieve Degraded Performance

Incident Report for SBCC IT

Resolved

SoftDocs has resolved the issue(s) on their end.
Posted Feb 07, 2025 - 11:42 PST

Identified

Etrieve is experiencing degraded performance due to an outage on the vendor's (SoftDocs) side. We will continue to monitor the situation and will update this notice when SoftDocs resolves the outage.
Posted Feb 07, 2025 - 11:25 PST
This incident affected: Softdocs Etrieve.