Canvas is not currently available.

Incident Report for SBCC IT

Resolved

This incident has been resolved.
Posted May 08, 2026 - 12:50 PDT

Investigating

Canvas is currently unavailable. Instructure, the vendor, has been notified and is actively investigating the issue. We apologize for the inconvenience and will provide updates as more information becomes available.

For real-time status updates, please visit https://status.instructure.com
Posted May 07, 2026 - 13:44 PDT
This incident affected: Canvas (<a href="https://status.instructure.com/" target="_blank">status.instructure.com</a>).