MySBCC portal outage

Incident Report for SBCC IT

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 15:25 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2025 - 12:52 PDT

Update

As a workaround, if you need to access the portal you can log into https://auth.sbcc.edu/sso and then click on "My SBCC Portal" to access the portal.
Posted Jun 17, 2025 - 09:35 PDT

Investigating

We are currently investigating an issue that is preventing users from logging into the my.sbcc.edu portal.
Posted Jun 17, 2025 - 09:15 PDT
This incident affected: Single Sign On Login and Campus Portal (MySBCC).