Banner Registration Incident

Incident Report for SBCC IT

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 10:05 PDT

Monitoring

We have made configuration adjustments to address the issue and are closely monitoring system performance throughout the day for any recurrence.
Posted Apr 23, 2026 - 09:27 PDT

Investigating

Registration in Banner Self Service is currently experiencing slowness and may take longer than usual to load or submit changes. You can still register, but pages may be slow or time out; if this happens, wait a moment and try again. Our IT team is working to improve performance right now, and we will post an update as soon as this issue is resolved.
Posted Apr 23, 2026 - 08:57 PDT
This incident affected: Banner (Banner PROD).