SecurePrint is offline - Student printing impacted

Incident Report for SBCC IT

Resolved

This incident has been resolved.
Posted Nov 27, 2023 - 10:55 PST

Investigating

We are currently investigating a problem with SecurePrint, the method by which students can print on campus from lab computers. Printing is currently offline at this time.
Posted Nov 27, 2023 - 10:05 PST
This incident affected: Campus Network Connectivity (Cliff Campus).