Password Reset Processing Delay

Incident Report for SBCC IT

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 16:32 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2025 - 14:37 PDT

Investigating

Password resets are currently experience a delay in processing time. Technicians are investigating this issue. If you reset your password and it is not working, please do not reset it again and just try again after 60 minutes. We appreciate your patience as we investigate this issue.
Posted Jun 25, 2025 - 13:26 PDT
This incident affected: Single Sign On Login and Campus Portal (MySBCC).