Delay in password resets

Incident Report for SBCC IT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2025 - 13:46 PDT

Investigating

Password resets are currently experiencing a delay in processing time. Technicians are investigating this issue. Please avoid resetting your password and try again later.
Posted Jun 12, 2025 - 13:31 PDT
This incident affects: Single Sign On Login.