Sign-on issues

Incident Report for SBCC IT

Resolved

The single sign-on issues have been resolved. Please contact our IT Support Desk if you are experiencing any problems logging into one of our systems. The contact information for the IT Support Desk is located at https://www.sbcc.edu/it/helpdesk.php. Thank you for your patience!

SBCC IT Support Desk
Posted Jun 11, 2025 - 11:57 PDT

Investigating

We are currently investigating an issue with our single-sign on portal, which provides login services to Google, Banner, and other enterprise systems. Existing connections work, but if anyone gets signed out they might not be able get back in.
Posted Jun 11, 2025 - 11:10 PDT
This incident affected: Single Sign On Login.