Internet Outage at Wake

Incident Report for SBCC IT

Resolved

The Internet connectivity issues at the Wake Campus have been resolved. A faulty switch was identified as the problem and was replaced. Thank you for your patience.
Posted Jun 24, 2025 - 13:34 PDT

Update

We are continuing to investigate this issue.
Posted Jun 24, 2025 - 13:33 PDT

Investigating

Information Technology (IT) is receiving reports that the Internet at the Wake Campus might be unavailable. Technicians are looking into the situation to determine the cause and a solution. Please be patient and monitor the SBCC IT Status Page for updates. That page is located at: https://status.sbcc.edu. Thank you for your patience!
Posted Jun 24, 2025 - 08:25 PDT
This incident affected: Campus Network Connectivity (Wake Campus).